Using XStream 1.4.8 in android 4.4 fails.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Using XStream 1.4.8 in android 4.4 fails.

Bruce Link
I believe that xStream being compiled against Java 8 removes the ability
for XStream to be used as a drop in module in android 4.4.

When I use 1.4.8 in eclipse as a module for my Android 4.4 project, I
receive a compile error along the lines of:

UNEXPECTED TOP-LEVEL EXCEPTION: com.android.dx.cf.iface.ParseException:
bad class file magic (cafebabe) or version (0034.0000)

Which I understand is due to an incompatible JDK version see:
http://stackoverflow.com/questions/24795161/how-to-use-a-java-8-library-with-android

This error does not appear when using version 1.4.7.

My apologies if this is a known issue already, I did my best to review
the mailing list and bug tracker.

Bruce

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Using XStream 1.4.8 in android 4.4 fails.

Jörg Schaible-2
Hi Bruce,

Bruce Link wrote:

> I believe that xStream being compiled against Java 8 removes the ability
> for XStream to be used as a drop in module in android 4.4.
>
> When I use 1.4.8 in eclipse as a module for my Android 4.4 project, I
> receive a compile error along the lines of:
>
> UNEXPECTED TOP-LEVEL EXCEPTION: com.android.dx.cf.iface.ParseException:
> bad class file magic (cafebabe) or version (0034.0000)
>
> Which I understand is due to an incompatible JDK version see:
> http://stackoverflow.com/questions/24795161/how-to-use-a-java-8-library-with-android
>
> This error does not appear when using version 1.4.7.
>
> My apologies if this is a known issue already, I did my best to review
> the mailing list and bug tracker.

I was unaware of Android not supporting Java 8. However, you can simply
remove the class files for the LambdaConverter and the LambdaMapper from the
archive. They are only used with a Java 8 runtime.

Cheers,
Jörg


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email